找回密码
 立即注册

易语言模块:读取验证码 易语言验证码识别模块.ec

[复制链接]
发表于 2023-5-21 00:03:20 | 显示全部楼层 |阅读模式
资源类型:易语言编程 » 源代码. 资源来源:网友投递
模块名称:读取验证码
作者:menlsong
版本:1.0
------------------------------
.子程序 读取GIF验证码, 字节集, 公开, 返回读取的验证码,默认格式为BMP。
.参数 验证码地址, 文本型
.参数 正确延迟, 整数型, 可空, 出现正确验证码时延迟的毫秒数,默认为200
.参数 返回格式, 整数型, 可空, 1、bmp;2、jpg;3、gif;4、tiff;5、png

.子程序 读取验证码, 字节集, 公开, 返回读取的验证码,默认格式为BMP。
.参数 验证码地址, 文本型
.参数 返回格式, 整数型, 可空, 1、bmp;2、jpg;3、gif;4、tiff;5、png

.子程序 二值法取图, 字节集, 公开, 图像转为黑白图.颜色中间值,可为空。去杂点 默认为假
.参数 原图像, 字节集
.参数 颜色中间值, 整数型, 可空
.参数 去边框量, 整数型, 可空
.参数 去杂点, 逻辑型, 可空

.子程序 二值式识别验证码, 文本型, 公开, 识别已二值化的验证码。验证码字符数:该验证码有几个字符,为空则自动获取
.参数 原图像数据, 字节集
.参数 特征码库, 文本型
.参数 验证码字符数, 整数型, 可空
.参数 字符最小宽度, 整数型, 可空, 默认为3
.参数 识别精度, 整数型, 可空, 可空,非零可进行模糊识别。0-10整数型 -1表示不返回问号(取最相近结果)。

.子程序 燃烧法取图, 字节集, 公开, 通过燃烧法取出字符
.参数 原图像, 字节集
.参数 字符最小宽度, 整数型, 可空, 默认为2
.参数 字符最大宽度, 整数型, 可空, 默认为4

.子程序 转换图像格式, 逻辑型, 公开, 支持bmp、jpg、gif、tiff、png互转。
.参数 图像数据, 字节集, , 被转换的图像数据
.参数 转换格式, 整数型, , 转换后的图片格式。1、bmp;2、jpg;3、gif;4、tiff;5、png
.参数 新图像, 字节集, 参考, 用于保存新图像的变量

17531398624[下载].rar



上一篇:易下载引擎.ec
下一篇:啄啄皮肤模块(内存版).ec

使用道具 举报

Archiver|手机版|小黑屋|吾爱开源 |网站地图

Copyright 2011 - 2012 Lnqq.NET.All Rights Reserved( 粤ICP备14042591号-1 )

关于本站 - 版权申明 - Ln Studio! - 广告联系

本站资源来自互联网,仅供用户测试使用,相关版权归原作者所有

快速回复 返回顶部 返回列表